Several of our carrier partners had issues due to regulatory changes. Inbound calling should be 100% restored. Outbound calling has been re-routed to another carrier partner. The carrier issues should be resolved today.
Bit by Bit is closely monitoring and continuing adjustments, with full stabilization of service expected to be resolved today. We appreciate your patience as we work to ensure consistent, reliable service.
Posted Aug 29, 2025 - 12:18 UTC
Update
Inbound calling is restored 100%. Outbound calling may still see slight performance degrade. BBB is still working with the problematic carrier to resolve outstanding issues
Posted Aug 28, 2025 - 23:23 UTC
Update
Bit by Bit is in the process of re-routing all outbound traffic to known good carriers. We are still working with the carrier where inbound numbers are impacted.
Posted Aug 28, 2025 - 14:03 UTC
Investigating
We are investigating a carrier outage that is impacting some inbound/outboung calling quality