Global CrowdStrike Incident
Incident Report for Bit By Bit Status Page
Resolved
This incident has been resolved.
Posted Jul 20, 2024 - 16:55 UTC
Monitoring
Dear Valued Clients,

We are writing to inform you about the recent global tech issues that were caused by a faulty update issued by cybersecurity vendor, CrowdStrike. The update has affected Windows PCs globally and caused outages in companies and cloud services that use CrowdStrike.

We want to assure you that Bit by Bit does not use CrowdStrike services or software on our infrastructure nor do we install CrowdStrike on our managed service clients that subscribe to endpoint protection. Therefore, your systems and data are not directly affected by this update.

We are aware and are closely monitoring outages with the following key vendors that are impacting our clients:

Microsoft 365

LogMeIn

Computer Patching, Backups and Disaster recovery are all critical parts of any firm's Cyber Security and considering today's events we will thoroughly review both our internal and client infrastructures to identify any software or service that is susceptible to a mass outage such as the one that happened today.

We appreciate your patience and understanding during this time. We value your trust and confidence in us as your MSP partner. If you have any questions or concerns, please do not hesitate to contact us.

Sincerely,

Bit by Bit
Posted Jul 19, 2024 - 21:36 UTC