Outbound calling should be restored through the teams platform. Please report any issues to support@bitxbit.com and we will investigate.
Posted Aug 29, 2025 - 13:41 UTC
Update
Several of our carrier partners had issues due to regulatory changes. Inbound calling should be 100% restored. Outbound calling does work, but it takes a long time before the call connects. This should be resolved today.
Bit by Bit is closely monitoring and continuing adjustments, with full stabilization of service expected to be resolved today. We appreciate your patience as we work to ensure consistent, reliable service.
Posted Aug 29, 2025 - 12:16 UTC
Update
Outbound performance is working but is taking a long time for calls to get connected. Inbound calling is working 100% now.
Posted Aug 28, 2025 - 23:24 UTC
Update
We are still researching this issue. We have opened a ticket up with Microsoft for their review
Posted Aug 28, 2025 - 14:02 UTC
Investigating
Microsoft Teams is having an outbound calling issue that we are investigating. Some inbound calls may be impacted as well